I am getting a PHP is_readable() warning

Symptom: You just installed or updated the theme and you now see a PHP Warning message that reads something close to:

Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(D:\Inetpub\vhosts\example.com\httpdocs/wp-content/plugins/ is not within the allowed path(s): (D:/Inetpub/vhosts//example.com\;C:\Windows\Temp\) in D:\Inetpub\vhosts\example.com\httpdocs\wp-includes\l10n.php on line 457

Cause: This warning is associated primarily, but not always, with MS Windows IIS web servers where the server has been configured with a open_basedir directive. That directive, some web administrators believe, makes the server more secure by preventing anyone but the owner of the effective directories from being accessed. This is not necessary on modern servers where you can configure restrictions on a per user basis anyway. So, what this warning is saying in layman’s terms is:

  • We have added the open_basedir directive, and because we did;
  • Your theme cannot access any folder other than Temp folder and the root examnple.com folder on this server.

How to solve this: Copy and paste the error in full and send it to your web hosting support service. Ask then to create an exception for the folder that is not permitting access by the Revolution Slider plugin. They will know what to do. If they will not assist you,you should consider changing hosts, or you will have to keep the Revolution Slider disabled in Theme Options -> Extra Options. There are no other options for resolving this issue.

Demo Content One click

If you’re looking for the demo contents, you can get them here